Back
Resolved

Domain issues with extellio.com

Started 22 Dec at 12:18pm CET.

Script Surveys App Reports Analytics API
Created

Due to a failed renewal of our primary domain extellio.com all our services was offline from midnight until around 10:00 on December 22. Once the root problem was resolved it took a couple of hours for the domain settings to propagate around the internet.

Posted 22 Dec at 12:18pm CET.